Intellispire Informer

Quick Stats

The Intellispire Software Installer is currently being run by over 10834 people on 20812 websites - including this one!

The Buzz

"Though I have to say, your tool is going to end up killing my freelance work [...]" - M.W. Merz

Members Login



iContact Plugin for Joomla!

Ask a question about this product

iContact Plugin
iContact Plugin
5.2
$29.00
platform
PayPal Buy Now

 

Works With:

 

Now! Joomla! 3.0 Compatible!

Intellispire's iContact Plugin is developed to act as a bridge between Joomla! and iContact Email Marketing Solutions. If you have an iContact account and Intellispire's iContact plugin installed, you are ready to start growing your list.

When people sign up at your Joomla website, they are added to your Joomla user list and automatically added to your iContact email list in the background. The simplified, flexible and seamless integration is just a few clicks away.

Following are some of the features of this must-have Joomla! Plugin.

check Smooth Integration between your Website and iContact

check 99% deliverability of your email messages and auto responders

check Manage your mailing lists with ease

check Manage Surveys

check Performance tracking of your blast email messaging campaigns.

check Manage your website's RSS Feeds.

check Automated iContact subscription for existing and new users of your website

check Instant, Ready-to-use Email Marketing in just few clicks.

check Easily integrate with JomSocial, CommunityBuilder and VirtueMart

check Smooth integration with Joomla 1.5, 1.6, 1.7, 2.5 and 3.0 Social Networking Extensions

check On-time Delivery and Extensive Customer Support

check Completely tested as per Joomla 1.5, 1.6, 1.7, 2.5 and 3.0 Quality Assurance guidelines.


Simple, Effective and Fast listbuilding using iContact autoresponders and Joomla

Hook iContact up to your Joomla 1.5, 1.6, 1.7, 2.5 and 3.0 native website. When someone registers at your site, they are added to your iContact email list

Intellispire's iContact Plugin is your 24 x 7 sales assistant. Equip your website with this plugin NOW.

 
Connect on Twitter
Connect on Facebook

System Requirements

Most Intellispire Joomla! Software works with PHP 5.2/5.3 and Joomla 1.5+ (including 2.5) or Wordpress 3.2+. Software is unencoded and licensed under the GPL. Hosting is available.

©2002-2012 Intellispire
Web Analytics